HTTP2 health check fails in Data Center when configuring CDN
Platform Notice: Data Center - This article applies to Atlassian products on the Data Center platform.
Note that this knowledge base article was created for the Data Center version of the product. Data Center knowledge base articles for non-Data Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The CDN administration screen in your Data Center application displays one of the following failed warnings:
Can’t check HTTP/2 connection
This browser can’t check whether you have a HTTP/2 connection. Use a different browser to make sure you can reach your CDN over HTTP/2.
HTTP/2 required
Your network infrastructure (such as your load balancer, firewall, or proxy) must allow HTTP/2 traffic. Learn more
Cause
Your load balancer, reverse proxy, or web application firewall has not been configured to allow HTTP/2 traffic, or the browser you are using does not fully support HTTP/2, so we can't complete the check.
While not mandatory, using HTTP/2 is highly recommended, and will provide the best performance for your end users.
Resolution
You will need to update your load balancer, proxy, or firewall configuration to allow HTTP/2 traffic. Check the documentation for your particular infrastructure to find out how to do this.
Note: a small number of browsers, such as Internet Explorer, don't fully support HTTP/2, which means our health check won't be able to check your HTTP/2 connection. We recommend switching to another browser if you see this message.